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Service software

Overview
The following steps will be required to use service software with RH-51/52, RH-67/68.

® Install Phoenix Service Software.

® Install data package for RH-51/52, RH-67/68.
e FPS-8 flash update.

e JBV-1 docking station SW update.

Phoenix

Phoenix is the new generation service software for reprogramming, testing and tuning
the phone. It has been designed to meet the challenges in servicing modern cellular
phone technology.

The Phoenix program has been built using component architecture. This means that the
actual program is small and most of the program'’s functionality is divided into dynami-
cally loaded modules (DLLs).

Supported operating systems
Windows 2000 and XP.

Hardware requirements for using Phoenix
Minimum:
Processor 300 MHz, RAM memory 64 MB, disk space 100 MB.

Recommended for Windows 2000:
Processor 700 MHz, RAM memory 256 MB, disk space 150 MB.

Introduction

This section briefly describes how to install the Phoenix software and includes some
basic information on how to use the program. For more detailed information, please refer
to Phoenix Help files. Each feature in Phoenix has its own Help function, which can be
activated while running the program.

Press the F1key or the feature's Help button to activate a Help file.

Installing Phoenix
Phoenix Service Software 2004.32.6.62 or later required.

It is recommended to uninstall the previous RH-51/52, RH-67/68 Phoenix package
before installing the new one. Do it as follows:

® Download the latest Phoenix release. Please contact your regional After Market Ser-
vices point for information on where to download the latest release.
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Download and read the release notes which have useful information on the software
Version you are using.

Download the latest data packages for the products you will be using.

Before you start installing the program, check that the dongle is attached to the
parallel port. Contact your supervisor in order to obtain a suitable dongle.
Administrator rights are required in order to be able to install Phoenix.

Install Phoenix by executing the Phoenix installation package and follow the
instructions on the screen.
Initially, the setup files are extracted into the file system.

Note: If the setup files are already extracted (left in the file system from previous
installation) the “"Overwrite Protection” dialog appears. Always click “Yes to All" to
overwrite the existing setup files.

The installation checks that the latest supported dongle driver version is installed.
The dongle driver is installed if there is no previous installation of the dongle driver
or if the installed dongle driver is older than the latest supported version.

Note: If the dongle driver is installed during installation, you need to reboot your PC
and restart the installation after reboot.

Program files are stored under C:\Program Files\Nokia\Phoenix (default).

Uninstalling Phoenix

If you need to remove Phoenix Service Software from your computer:

Make sure that the dongle is attached.
Go to the Control Panel and select Add/Remove Programs.
Select Phoenix Service Software Axx 200x.XX.X.XX.

Click Change/Remove then OK to remove the application.

You may have to reboot your PC after uninstallation.

Data packages

The product data package contains all product specific data to make the Phoenix Service
Software and tools usable with a certain phone model. Each product has its own data
package (DP).

Data files are stored under C:\Program Files\Nokia\Phoenix (default).

It also includes the latest version of the flash update package for FLS-4S* and FPS-8*.

Before installation
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Check that the dongle is attached to the parallel port of your computer.

Install Phoenix Service SW.
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e Download the installation package (e.g. RH-51_dp_EA_v_1_0.exe) to your computer
(e.g. C:\TEMP).

® C(Close all other programs.

® Run the installation package (e.g. RH-51_dp_EA_ v_1_0.exe) and follow the instruc-
tions on the screen.

If you already have the Phoenix Service SW installed on your computer, sooner or later
there will be need to update it when new versions are released.

Please note that very often the Phoenix Service SW and the phone specific data package
for Phoenix come in pairs, meaning that a certain version of Phoenix can only be used
with a certain version of the data package. Always use the latest available versions of
both. Instructions can be found in phone model specific Technical Bulletins.
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Installing Phoenix data package (product specific)
Run the installation package (e.g. RH-51_dp_EA_ v_1_0.exe to start the installation.

When you choose Next the files needed for installation will be extracted. Please wait.

_sféRH-Sl_dp_EA_RE ¥_5_0_MCU3_0415_0 - InstallShield Wi

Extracting Files
The contents of this package are being extracted.

Please wait while the InstallShigld Wizard extracts the files needed ko instal
RH-51 dp EA_RC_ v 5 0 MCU3 0415 0 on your computer, This may take a few
maments,

Reading contents of package...

-

Installshield

< Back MERE = Cancel

Choose Next to continue.

InstallShield Wizard ) x|

Welcome to the InstallShield Wizard for RH-51
Phone Data Package EMEAJAPAC

The InstallShield® Wizard 2.6 will install RH-51 Phone:
[ata Package EMEAZAPAL version 5.0, To continue,
click Mext.

¢ Black | WNewt > I Cancel

In this view, you can see the contents of the data package.

Read the text carefully.

There should be information about the Phoenix version needed with this data package.
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Choose Next.
x

Information 3
Please read the following test, I ] il

Y
RH-51 Phohe Data Package w.3.0415.0 Installation j

MOTE M You MUST uze Phoenix release 2004.08.0.37 or hewer. See Technical bulletin b
detailed information on user settings hatdling with Phosnix . 2004.08.0.37 11

Matel If some earlier verzsion of BH-51 Phone Data Package iz already installed,
it muzt be ukinstalled first. Cloze Phosnix before starting uninstallation
or installation of Data Package. Go to Add/Remove Programs in Contral Panel, _ILI
3

4 |

|rstallShield

< Back | MNext » I Cancel |

Confirm location and choose Next to continue.

InstallShield Wizard B |
Chooze Destination Location N
Select folder where Setup will install files. I ] :,,.I

Setup will install RH-51 Phone Data Package EMEAAAPAC in the following folder.

Toinztall ta this folder. click Next. To install to a different folder, click Browse and select
another folder.

C:WProgram Files\M okiahPhoenix Browsze... |

|ratallShield

" Destination Folder

< Back | WNewt > I Cancel |

The install shield checks where the Phoenix application is installed and the directory is
shown.
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Choose Next to continue.

InstallShield Wizard .

Start Copying Files

To start installing the files, click Mexst,

Current Sethings
Inzstallation path: C:\Program Files' okiasPhoenis ;l

o i

|rstallShield

< Back | MNext » I Cancel |

Phone model specific files will be installed. Please wait.

Installshield Wizard il . il

Setup Status

RH-51 Phone Data Package EMEASAPAL Setup is performing the requested operations.

Inztalling:
C:%Program FilestMokia'PhoeniproductziBH-514RHETPE 3041 50,03

- o

|ratallShield

Cancel
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Choose Finish to complete the installation.

Installshield Wizard

InstallShield Wizard Complete

The InstallShield Wizard has successfully installed AH-51
Phone Data Package EMEA/APAC. Click Finish bo exit the
wizard.

¢Back |E Fimsh i Careel

You now have all phone model specific files installed in your Phoenix Service SW.

Uninstalling Phoenix data package
Uninstallation can also be done manually from Windows Control Panel / Add / Remove
Programs/"RH-51 Phone Data Package".

If you try to install the same version of Phoenix data package that you already have, you
are asked if you want to uninstall the version you have on your PC. Answer OK to unin-
stall, Cancel if you don't want to uninstall. Older versions of data packages do not need
to be uninstalled.

Uninstall RH-51 Phone Data Package EMEA,/APAC x|

Do vou want to completely remove the RH-51 Phone Data Package EUR application
and all of its components?

oK I Cancel |

Once the previously installed data package is uninstalled, choose Finish.

Run the installation package again to continue installation from the beginning.

FPS-8 flash update
Flash update 3.14.000 or later required.

When you have a connection established to FPS-8, and FPS-8 has been activated, the
first thing to do is to check that you have the correct application SW version inside FPS-
8. Phoenix SW can check that automatically.
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The procedure for manual update is as follows:

e Start Phoenix SW.
® Click on Flashing.
e Click on FPS-8/FPS-8C Maintenance.

e |f SWinside FPS-8 prommer is too old, you get the notification:
Click Yes.

You see on the small screen as the Prommer goes to service mode (mode2 is lit) SW goes
into box, application SW, secondary boot codes and algorithm codes are updated.

JBV-1 docking station SW update

The JBV-1 docking station is a common tool for all DCT-4 generation products.

In order to make the JBV-1 usable with different phone models, a phone specific docking
station adapter is used for different service functions.

The JBV-1 docking station contains software (Firmware) which can be updated.
You need the following equipment to be able to update JBV-1 software:

e PC with USB connection
e operating system supporting USB (not Win 95 or NT)

e USB cable (can be purchased from shops or suppliers providing PC hardware and
accessories).

* JBV-1 docking station.
e external power supply 11-16V.

Before Installation:

e Download Jbvi_update.zip - file to your computer (e.g. C:\TEMP) from your down-
load web site.

® C(Close all other programs.

Installing SW needed for the JBV-1 SW update
DO NOT CONNECT THE USB CABLE / JBV-1 TO YOUR COMPUTER YET!

Run Jbv1_update.zip file and start SW installation by double clicking Setup.exe.

Follow the instructions, then all files needed for the JBV-1 package setup program are
installed.

NOW YOU CAN CONNECT THE USB CABLE / JBV-1 TO YOUR COMPUTER!

Connect power to JBV-1 (11-16V DC) from an external power supply, then connect the
USB cable between JBV-1 USB connector and PC.
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Windows will detect the connected USB cable and drivers for the new HW. Please follow
the instructions and allow Windows to search and install the best drivers available. After
this procedure, the actual JBV-1 SW update can begin.

Updating the JBV-1 docking station software

Go to folder C:\Program Files\Nokia\ JBV-1 SW Package\ FIRMIWARE UPDATE and start the
JBV-1 Update SW by double clicking fwup.exe.

The JBV-1 firmware update starts and shows the current status of the JBV-1 connected.

If the firmware version read from your JBV-1 is not the latest one available, it needs to
be updated by choosing Update Firmware.

Choose file JBV1v18.CDE (example used here is for v 18) and Open to update your JBV-1.

After a successful update, the current JBV-1 status is shown. You have now updated the
software of your JBV-1 docking station and it is ready for use.
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Reprogramming RH-51/52, RH-67/68

Setup

Open RH-51, RH-52, RH-67 or RH-68, remove the battery and SIM, then attach it to the
SF-21 adapter. Once connected to the SF-21, the phone goes to local mode and the
screen will not show anything during the SW update.

Note: More than 32MB SRAM required in FPS-8.

Proceed as follows:

e (Connect XCS-4 cable from SF-21 to FPS-8.
e Connect FLC-2 cable from FPS-8 to SF-21.

There is no need to press the phone power key. Phone has set itself automatically to local
mode and it is now ready for SW update.

Start Phoenix SW by double-clicking the Phoenix icon on your desktop.

® Choose File->Manage Connections.
* Click FPS-8 COM1 FBUS.
e (lick Apply, and then close the dialog.

® Choose File->Scan Product. If the phone is ok, you should see the SW version in
lower right-hand corner, for example V1.31.0.

If the scanning finds nothing, the phone is most likely in a strange mode.

Settings backup/restore
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MMC user data backup is strongly recommended since it's faster than over Phoenix. All
user data will be erased during updating the software by the data package.

Menu -> Extras -> Memory-> Options -> Backup phone memory.

If MMC is not available or doesn't have enough area left, backup the settings using
Phoenix.

® C(Click Product in menu bar.

® C(lick User settings.

e Click All Settings.

® Check All or check each item which you need to backup.

e  (lick Save.

e Select folder and input file name.
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_i5ixd
— Setting:
Hame Status Type -

V| :SOS General settings Ok USER
¥l | 505 Phonebook Ok USER
v| | S0S Messaging Centre Ok USER
vl | 505 Phato Album Ok USER
vl |SOS T9 Dictionary Ok USER
vl |S0OS Ringing Tones Ok USER
vl |SOS Operator Logos Ok USER
v| |SOS User profile settings Ok USER o
v |SOS WL Browser settings Ok USER
¥l | 505 WML Browser Bookmarks | OK USER
v| |S0OS Date & Time settings Ok USER
vl | 505 GFRS settings Ok USER
vl |SOS Bluetooth settings Ok USER
vl | 505 Calendar / To-Da list oK USER
vl | SOS Caloulator settings Ok USER
vl |SOS Pinboard settings Ok USER LI
Select zetting:

’7 @ Al O Faled ¢ Producion ¢ User ¢ Mone ‘
Configuration file

’V IE:\Program FileziMokiaPhoenixhproductshAH-514RH_51.ini

Browse... | Save... frite... Lag Lloze Help

Updating software

Choose Flashing -> FPS-8 Flash -> Choose Restore User Phone or Phone as Manu-
factured -> Uncheck Manual File Selection. Then click on Flash.

Now, in the Flash file selection window, choose the product code.

Appropriate files will be selected automatically:

Now click OK, and SW update starts.

You will see as the package goes into FPS-8, erasing and programming the phone.

If transfer is very slow, it is recommended that the parallel port is in the ECP mode.

Transfer in the ECP mode is much faster. If you do not know how to change the PC paral-
lel port mode from BIOS, contact your local support.

When SW update has ended, the yellow led stops blinking and you get a note in windows
SW.

You will get instructions to turn the phone on. Push the power key to turn on the phone,
then wait for 15 seconds.

Choose File -> Scan product. In the bottom of the Phoenix window you should see the
latest SW version.

Restoring settings

Issue 3 09/2004

Restore user settings from MMC or Phoenix.
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Service concept and setup

Flash concept

Point of Sales flash loading adapter SF-21 0770685
Power cable FLC-2 0730185
Modular cable XCS-4 0730178
Flash prommer box sales pack FPS-8 0080321
Printer cable AXP-8,

incl in FPS-8 sales pack
D9 - D9 cable AXS-4, 0730090

incl in FPS-8 sales pack
Software protection key PKD-1 0750018
AC Charger, ACF-8, 0680032

incl in FPS-8 sales pack
SRAM Module (3 pcs needed inside SF12 0080346 (Code
FPS-8) includes one SRAM

module)

Note: More than 32MB SRAM required in FPS-8.

© 2004 Nokia Corporation.
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POS flash concept

Item Description Type Code

1 Point of Sales flash loading adapter SF-21 0770685
2 Service cable XCS-1 0730218
3a FLS-4S sales pack for EMEA FLS-4S 0080541
3b FLS-4S sales pack for APAC FLS-4S 0080542
3c FLS-4S sales pack for US FLS-4S 0080543

Note: More than 32MB SRAM required in FPS-8.
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JBV-1 flash concept

1 Docking station adapter DA-18 0770682
2 Docking station adapter JBV-1 0770298
3 Power cable PCS-1 0730012
4 Modular cable XCS-4 0730178
5 Flash prommer box sales pack FPS-8 0080321
6 Printer cable AXP-8,
incl in FPS-8 sales pack
7 D9 - D9 cable AXS-4, 0730090
incl in FPS-8 sales pack
8 Software protection key PKD-1 0750018
9 AC Charger, ACF-8, 0680032
incl in FPS-8 sales pack
10 SRAM Module (3 pcs needed inside SF12 0080346
FPS-8) (Code includes one SRAM
module)

Note: More than 32MB SRAM required in FPS-8.
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Module jig flash concept

Flashing with MJ-25 is recommended in local mode.

The following equipment is required for RH-51/52, RH-67/68 AMS SW update when the
system module is placed in the module jig MJ-25 and connected through a FPS-8 set-up:

Item Description Type Code
1 Module jig MJ-25 0770683
2 Power cable PCS-1 0730012
3 Modular cable XCS-4 0730178
4 Flash prommer box sales pack FPS-8 0080321
5 Printer cable AXP-8,
incl in FPS-8 sales pack
6 D9 - D9 cable AXS-4, 0730090
incl in FPS-8 sales pack
7 Software protection key PKD-1 0750018
8 AC Charger, ACF-8, 0680032
incl in FPS-8 sales pack
9 SRAM Module (3 pcs needed inside | SF12 0080346 (Code includes
FPS-8) one SRAM module)

Note: More than 32MB SRAM required in FPS-8.
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Module jig service concept
This concept is for troubleshooting and RF calibration.

MJ-25 is intended for use with an external power supply.
MJ-25 input voltage: normal +6V, maximum +12V.

Ensure that the jumper is set open for voltage regulation before the external power sup-
ply is connected.

When FPS-8 is used as the power supply (4V), the jumper should be set close to bypass
regulator

EM calibrations including Zocus are only done with JBV-1. Module jig MJ-25 doesn't
support Zocus calibration in RH-51/52, RH-67/68.

1 Module jig MJ-25 0770683
4 RF cable XRF-1 0730085
5 Power cable PCS-1 0730012
7 MBUS cable DAU-9S 0730108
8 Software protection key PKD-1 0750018
9 External DC power supply
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JBV-1 service concept

This concept is for BB and RF calibration.

EM calibration including Zocus should be carried out in JBV-1 and DA-18.

Power to JBV-1 should be supplied from an external DC power supply, NOT FPS-8.

JBV-1 input voltage: normal +12V, maximum +16V.

A-cover and RF antenna module need to be removed from the phone when SA-29 is

attached.

Item Description Type Code

1 Docking station adapter DA-18 0770682
2 Docking station adapter JBV-1 0770298
3 RF adapter SA-29 0770686
4 RF cable XRF-1 0730085
5 Power cable PCS-1 0730012
6 DC cable SCB-3 0730114
7 MBUS cable DAU-9S 0730108
8 Software protection key PKD-1 0750018
9 External DC power supply
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